问答

在ubuntu 14.04上安装laravel时,php-ext-mcrypt错误

 来源    2018-11-08    1  

我在ubuntu 14.04的初学者在laravel.
我尝试运行下面的安装laravel的表扬.

composer create-project laravel/laravel --prefer-dist

我收到以下错误.
我也尝试安装ncrypt,但我有相同的错误.

Installing laravel/laravel (v5.0.1)
      - Installing laravel/laravel (v5.0.1)
        Loading from cache

    Created project in /opt/lampp/htdocs/laravel
    Loading composer repositories with package information
    Installing dependencies (including require-dev)
    Your requirements could not be resolved to an installable set of packages.

      Problem 1
        - laravel/framework v5.0.2 requires ext-mcrypt * -> the requested PHP extension mcrypt is missing from your system.
        - laravel/framework v5.0.1 requires ext-mcrypt * -> the requested PHP extension mcrypt is missing from your system.
        - laravel/framework v5.0.0 requires ext-mcrypt * -> the requested PHP extension mcrypt is missing from your system.
        - Installation request for laravel/framework 5.0.* -> satisfiable by laravel/framework[v5.0.0, v5.0.1, v5.0.2].

我也试图运行这个命令,但我有同样的错误.

sudo apt-get install mcrypt php5-mcrypt
sudo php5enmod mcrypt
sudo service apache2 restart

提前致谢..

我打开这个文件

gedit /etc/php5/cli/php.ini

把一行放到这个文件中

extension=mcrypt.so

并且此运行成功.

任何方式再次感谢

相关文章
php – ‘vagrant up’在ubuntu 14.04上安装宅基地时无法正常工作
问答我运行ubuntu 14.04可靠.我安装了虚拟盒子和流浪汉,以便能够使用laravel.我通过git安装了laravel宅基地,我正在尝试运行命令'vagrant up'但是我收到错误.请问我做错了 ...
1
python – 在Ubuntu 14.04上安装Pillow时出错
问答我试图安装Pillow在Ubuntu 14.04使用这个命令: pip install Pillow 但安装失败,出现此错误: ValueError: --enable-jpeg requested ...
2
在Ubuntu 14.04上安装Meteor时出现问题
问答我在Ubuntu 14.04上安装Meteor时遇到问题.我搜索了之前的答案,但没有一个问题与我有相同的问题. 当我运行meteor网站上给出的命令时: sudo curl https://insta ...
1
尝试在Ubuntu 14.04上安装Lightworks时,依赖性是不可满足的:libtiff4
问答我试图在Ubuntu 14.04(amd64)上安装Lightworks 11.5.1(amd64)但是有一个通知:依赖性不可满足:libtiff4. 无论如何要解决这种依赖问题吗? 提前致谢.::L ...
2
Vagrant在Ubuntu 14.04上安装NFS时挂起
问答直到今天,我的流浪汉设置工作顺利.但事情发生了,我无法找到什么. 突然间,当我进行流浪时,它会在挂载NFS共享文件夹时挂起. 我的猜测是由于主机上的一些更新导致了一些问题.以下是vagrant up ...
1
php – 在Ubuntu 14.04上使用Laravel 5.1的Localhost错误
问答看过以前的文章,但没有运气.我刚刚通过作曲家安装了Laravel 5.1.我一直在关注安装的官方文档,位于here.我没有使用家园,我也没有使用虚拟环境.虽然一切正常,但我在Web服务器上托管项目时遇 ...
1
在Ubuntu 14.04上安装带有RVM的Ruby 2.2.2时出错
问答这是什么. 我先做了: rvm get stable rvm install ruby-2.2.2 没有成交.它向我展示了以下内容: $rvm install ruby-2.2.2 Searching ...
1
未满足的依赖!在新安装的ubuntu 14.04上安装Cuda 6.5时
问答我按照教程here安装Cuda 6.5,当我尝试apt-get install cuda时,我收到以下错误: The following packages have unmet dependencie ...
2
software-installation – 在Ubuntu 14.04上安装Visual Studio代码时出错
问答我今天在我的Ubuntu 14.04计算机上发布后,一直试图安装MS Visual Studio Code.我已经阅读了官方文档并设置了from Microsoft,并且我已经阅读了question ...
2
node.js – 在Ubuntu 14.04上安装Socket.IO时出现构建错误
问答我似乎多次得到同样的错误.我一直得到这个(node-gyp rebuild 2> builderror.log)|| (退出0)消息.究竟是什么? socket.io也不再包含node.js r ...
2
ruby-on-rails – 无法在Ubuntu 14.04上安装kgio 2.8.1
问答注意:我正在运行Ubuntu,而不是Windows. 这是尝试安装kgio时发生的情况.我是否缺少依赖项,我应该安装什么? gilani@debris$gem install kgio -v '2.8 ...
1
无法在Ubuntu 14.04上安装apache2
问答我无法在Ubuntu 14.04上安装apache2. 在执行 sudo apt-get install apache2得到以下错误: – The following packages have un ...
1
java – 在ubuntu 14.04上安装tomcat 8.0.24
问答我主要从https://www.digitalocean.com/community/tutorials/how-to-install-apache-tomcat-8-on-ubuntu-14-04开 ...
2
debian – 在ubuntu 11.04上安装supervisord时出错.有任何解决这个问题的方法吗?
问答# aptitude install supervisor The following NEW packages will be installed: python-medusa{a} python- ...
2
在Ubuntu 16.04上安装OpenCV时出错
问答我一直试图在Ubuntu 16.04上安装OpenCV unsing几个教程,我总是最终出错.这是我在本教程后面的最后一个: https://github.com/BVLC/caffe/wiki/Ub ...
2
ruby-on-rails – 在Ubuntu 14.04上安装GitLab的位置是什么?
问答在Ubuntu Server 14.04上按照https://about.gitlab.com/downloads/的说明安装了GitLab,但是我找不到安装目录.它通常被称为/ home / git ...
5
ruby-on-rails – 在ubuntu 14.04上安装rmagick gem
问答我试图在OpsWorks上部署一个应用程序,但是安装rmagick宝石有问题.我有以下操作系统包: libmagickwand-dev imagemagick libmagickcore-dev 以下 ...
2
scala – 在Ubuntu 18.04上安装sbt时出错:`gpg:keyserver receive failed:参数无效
问答我跟着official sbt install instructions. $sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 -- ...
1
无法在Ubuntu 14.04上安装python pip
问答这是我用来安装python-pip的命令 sudo apt-get install python-pip 我收到以下错误 Reading package lists... Done Building ...
1